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The purpose of this book is to give guidance to the aspiring in EPC Companies, who 

dreams to become an experts in project management with knowledge of MS-Excel, MS 
Project, Primavera and SAP & ERP. Further, this book will give you a comprehensive 

idea about the useful report generation using charts, graphs, etc. I believe that this book 
will enable you use your brain up to the fullest to work smartly and achieve your goal in 

all endeavor. I fervently hope that this book will help the managers / Leaders to get a 
sound understanding of how to plan your work and achieve your goals. I’m sure that this 

book fundamentally will increase your capability of getting good score in your 
organization, entrepreneurship and interviews in a stress-free manner. 

I shall be happy to entertain your asserted valued commendations regarding inaccuracies 

and errors, and graciously make suggestions for further improvement of the book, 
deemed to be a fountain of my inspirations, a new lease of hope, which will enable my 

quest for betterment & further development.  

Please, feel free to get in touch with me through mailto: swarup_recj97@rediffmail.com, 
swarupdas1264@gmail.com and thru Mobile.: +91.8860451297 

✡ Copyright Note: The user is welcome to copy parts of this book, but only for personal 

use. All other rights of reproduction in any form by any electronic or mechanical means 

are reserved by the author. 

✡ Disclaimer: This book is an independent publication and it does not affiliate or 

sponsored by any other author or any agency. 
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This Book will enhance you : 

👌- to stimulate your excellent Thoughts! And revive your working skills. 

👌- to create Self Awareness for sustaining personal and professional growth & success. 

👌- to create platform for Self-empowerment for Managing & Leading in corporate world. 

👌- to produce better valuable outcomes more smartly, efficiently and more consistently. 
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out to my notice as consents. The suggestions for enriching the quality and usefulness of 
the book are most welcome and will be gratefully acknowledged with full fidelity.   

Those who might communicate their comments and criticism to me are very welcome. 
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1. Data Analysis Using Excel 
 

As data strategies become pervasive (universal) in all business and institutional 
sectors. Microsoft Excel is one of the top tools for data analysis and the built-in 
pivot tables are arguably the most popular analytic tool. Excel will become even 
more popular as a bridge tool for non-data scientists doing more work, more often, 
with data. It is a very powerful data analysis tool and almost all big and small 
businesses use Excel in their day to day functioning. We use Excel to do our 
calculations, and all math formulas are given as Excel Spreadsheets, but we do not 
attempt to cover Excel Macros, Visual Basic, Pivot Tables, Data filters, functions, 
formulas, transpose, vlookup or other intermediate-to-advanced Excel 
functionality. We need to explore various advanced graphing and charting 
techniques available in Excel. Starting with various line, bar and pie, pivot charts, 
scatter plots and histograms to present a set of non-structured and scattered data 
in a sophisticated and easy to understand manner.  
Refer Book: “Advanced Excel with VBA Macros” by Swarup Das 
 

Project Execution Plan 
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2. Data Analysis using MS Project (MSP) 
 

The following are the 5 basic elements of MSP: 
1. Scheduling 
2.  Executing 
3. Monitoring 
4. Rescheduling 
5. Report Generation 

 
MSP, the project management software program by Microsoft, is a very handy tool 
for project managers that helps them develop a schedule, assign resources to tasks, 
track the progress, manage the budget, and analyze workloads for an ongoing 
project. 
 
Project creates budgets based on assignment work and resource rates. As 
resources are assigned to tasks and assignment work estimated, the program 
calculates the cost, equal to the work times the rate, which rolls up to the task level 
and then to any summary task, and finally to the project level. 
 
A blank project file can be daunting (intimidating), especially if you’re new to 
project management. But with a few clicks, you can tap the power of Project to 
convert your to-do list into a full-fledged project for you to manage and share with 
your team and stakeholders. 
Here are a few starting points: 
 Add tasks 
 Outline tasks 
 Link tasks 
 Change your view 
 Print your project 

 
Step 1 − File → OpƟons → General tab → Project view → Default view. 
Select “Gantt with Timeline” from the dropdown box. 
Step 2 − File → OpƟons → Display tab → Show Indicators and OpƟons BuƩons For. 
Check all options. 



Page 7 of 66 
 

Step 3 − File → OpƟons → Schedule tab → Schedule → Show Assignment Units. 
Choose “percentage” from the dropdown box. 
Step 4 − File → OpƟons → Schedule tab → CalculaƟon → Calculate Project aŌer 
Each Edit. 
Check the On button. 
Step 5 − File → OpƟons → Save tab → Save projects → Save Files In this format. 
Select Project (*.mpp). 
Step 6 − File → OpƟons → Advanced tab → Edit. 
Check all options. 
Step 7 − File → OpƟons → Advanced tab → Display → Show Status Bar → Show 
Scroll Bar. 
Both options, Status Bar and Scroll Bar should be checked. 
Step 8 - Resources → Level → Leveling OpƟons → Leveling CalculaƟons. 
Set to manual. 
Step 9 − Resources → Level → Leveling OpƟons → Leveling calculaƟons → Look for 
Overallocations. 
Select “Day By Day” from dropdown box. 
 
A project manager should also be able to answer other project-related questions 
as well. For example − 
 Why this project needs to be run by the organization? 
 What’s the best way to communicate project details to the stakeholders? 
 What is the risk management plan? 
 How the vendors are going to be managed? 
 How the project is tracked and monitored? 
 How the quality is measured and qualified? 

 
MS Project can help you − 
 Visualize your project plan in standard defined formats. 
 Schedule tasks and resources consistently and effectively. 
 Track information about the work, duration, and resource requirements for 

your project. 
 Generate reports to share in progress meetings. 
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Create a New Plan 

When working with MS Project you either specify a start date or a finish date. 
Because once you enter one of the two, and other project tasks, constraints and 
dependencies, MS Project will calculate the other date. It is always a good practice 
to use a start date even if you know the deadline for the project. 
 

Set Up Resources 

In project management terminology, resources are required to carry out the 
project tasks. They can be people, equipment, facilities, funding, or anything 
(except labor) required for the completion of a project task. Optimum Resource 
Scheduling is the key to successful project management. 
 

Resource Types 

 Work resources − People and equipment to complete the tasks. 
 Cost resources − Financial cost associated with a task. Travel expenses, food 

expenses, etc. 
 Material resources − Consumables used as project proceeds. For example, 

paint being used while painting a wall. 
 
Note: Be aware of the crucial difference between People and Equipment resources. 
People resources will have limited work hours, say 6, 8 or 12 hours. Equipment 
resources have different working capacities of 2, 8 or 24 hours and could have 
maintenance breaks as well. Also note, that it is possible multiple people resources 
might be using one equipment resource, or one equipment might be accomplishing 
multiple tasks. 
 

Steps involved 

Click View tab → Resource Views group → Click Resource Sheet. 
Click the cell directly below the Resource Name heading column. 
Enter Resources as an individual person, job function or group. 
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Assign Resources to Task 

Once the task and resource list are complete, resources need to be assigned to 
tasks in order to work on them. With MS Project you can track task progress, 
resource and tasks costs. 
Steps involved 

Click View Tab → GanƩ Chart View → Resource Name column. 
Click the box below the Resource Name column for the task you need the resource 
to be assigned. 
From the dropdown, choose the resource name.  
 

Plan Duration, Cost & Time 

After assigning resources to tasks you can view the cost, duration and work 
required for the plan to complete. 
 

Check Plan’s Duration 

In Gantt Chart View → View Tab → Split View group → Timeline checkbox. 
You will be able to see the plan’s start and finish dates. 
In the Gantt Chart view, you can also look at the project summary task, to note the 
duration, start and finish dates of the plan. 
 
Check Plan’s Cost 

Click View tab → Data group → Tables → Cost. 
Cost for each task gets rolled up into summary tasks, and then ultimately to project 
summary task. 
 

Check Plan’s Work 

Click Report Tab → View Reports group → click Resources → click Resource 
overview 
 
In Resource status table which appears at the bottom, you will get a summary of 
resource’s earliest start dates and latest finish dates as well as remaining work. 
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Check Project Statistics 

Click Project Tab → ProperƟes group → Project Information → in the new dialog 
box click Statistics… 
 

Track Progress 

Once your project plan is ready in MS Project, it becomes essential for a project 
manager to measure the actuals (in terms of work completed, resources used and 
costs incurred) and to revise and change information about tasks and resources 
due to any changes to the plans. A Project Manager should not assume that 
everything is progressing according to plan and should always keep track of each 
task. Resistance to formal tracking of project management data is normal. You can 
overcome resistance to tracking by explaining your expectations, explaining the 
benefits of tracking, and training people to track the task themselves. 
 

Save a Baseline 

To evaluate project performance you need to create a baseline against which you 
will compare the progress. One needs to save the baseline, once a plan is fully 
developed. Of course, due to rolling wave planning or progressive elaboration 
needed to manage projects one can always add new tasks, resources, constraints 
and costs to the plan. 
Also note, it makes sense to save the baseline before entering any actual values 
such as percentage of task completion. 
 

Advanced Scheduling 

There are four types of task dependencies. 

 Finish to Start (FS) − Finish the first floor before starƟng to build the second 
floor. Most used. 

 Finish to Finish (FF) − Cooking all the dishes for dinner to finish on Ɵme. 
 Start to Start (SS) − When doing a survey, we would seek survey responses 

but will also start tabulating the responses. One does not have to finish 
collecting survey responses before starting the tabulation. 

 Start to Finish (SF) − Exam preparaƟon will end when exam begins. Least 
used. 
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Adjust Task Link Relationship 

Click Task Tab → double-click the required task under Task Name column → 
   Task Information dialog box opens → Predecessors Tab. 
 
Click the box under the Type column and choose the relationship according to your 
requirement. 

 
Status Reporting 

After creating a project plan and baselines, the project begins. At this stage, the 
project manager would be focusing on collecting, monitoring, analyzing project 
performance, and updating project status by communicating with the 
stakeholders. 
When there is a difference between what is planned and the actual project 
performance, it is called a Variance. Variance is mostly measured in terms of Time 
and Cost. 
 

Task Slippage 

There are several ways to view task with variance. 
 

Method 1: Graphical View by Tracking Gantt 

Click View tab → Task Views group → GanƩ Chart dropdown → Tracking GanƩ. 
By comparing the currently scheduled Gantt bars with baseline Gantt bars, you can 
see what tasks started later than planned or took longer to complete. 

 
Method 2: Graphical View by Detail Gantt 

 

Method 3: Variance Table 

Click View tab → Data group → Tables → Variance. 
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Method 4: Filters 

Click View tab → Data group → Filters → More  
   Filters → choose filter as Late tasks, Slipping task, etc. 

 
Task Costs 

To examine cost in a project life cycle, you should be aware of these terms and 
what they mean in MS Project 2013 − 
 Baseline costs − All planned costs as saved in baseline plan. 
 Actual costs − Costs that have been incurred for tasks, resources, or 

assignments. 
 Remaining costs − Difference between baseline/current costs and actual 

costs. 
 Current costs − When plans are changed due to assigning or removing 

resources, or adding or subtracting tasks, MS Project 2013 will recalculate all 
costs. This will appear under the fields labeled Cost or Total Cost. If you have 
started to track actual cost, it will include actual cost+ remaining cost 
(uncompleted task) per task. 

 Variance − Difference between Baseline Cost and the Total Cost (current or 
scheduled cost). 

Click View Tab → Data group → Tables → Cost. 
 
You will be able to view all relevant information. You can also use filters to see tasks 
that have run over budget. 
Click View tab → Data group → Filters → More Filters → Cost Overbudget → Apply. 
 

Resource Cost 

For some organizations, resources costs are primary costs, and sometimes the only 
cost, so these need to be closely watched. 
Click View tab → Resource Views group → Resource Sheet. 
 
Click View tab → Data group → Tables → Cost. 
We can sort the Cost column to see which resources are the most and least costly. 
Click the AutoFilter arrow in Cost column heading, when the drop-down menu 
appears, click on Sort Largest to Smallest. 
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You can use the AutoFilter feature for each of the columns, By sorting Variance 
column, you will be able to see the variance pattern. 
 

Project Report 

Project comes with a set of predefined reports and dashboards. You’ll find all of these 
on the Report tab. You can create and customize graphical reports for your project as 
well. 

Dashboard Reports 

Click Report → View Reports group → Dashboards. 

Resource Reports 

Click Report → View Reports group → Resources. 

Cost Reports 

Click Report → View Reports group → Costs. 

Progress Reports 

Click Report → View Reports group → In Progress. 

Custom Reports 

Click Report → View Reports group → New Report. 

There are four options. 

 Blank − Creates a blank canvas. Use the Report Tools - Design tab to add charts, 
tables, text, and images. 

 Chart − Creates a chart comparing Actual Work, Remaining Work, and Work by 
default. Use the Field List pane to pick different fields to compare. The look of the 
chart can be changed by clicking on Chart Tools tabs, Design, and Layout tabs. 

 Table − Creates a table. Use the Field List pane to choose what fields to display 
in the table (Name, Start, Finish, and % Complete appear by default). Outline level 
box lets you select how many levels in the project outline the table should show. 
The look of the table can be changed by clicking on Table Tools tabs, Design, 
and Layout tabs. 

 Comparison − Creates two charts side-by-side. Charts will have the same data 
at first. You can click one of the charts and pick the data you want in the Field List 
pane to begin differentiating them. 
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MSP Practical using Software 

Creating a Blank Project & Project Information 

MS project includes the list of options mentioned below in the Project Information. When 
you open the MS Project, from the available templates, you need to click on the Blank 
Project as shown below.  

The project sets the start date of the plan to the current date. This date is indicated by 
the green thin vertical line in the chart part of the Gantt Chart View. 

 
Step 1: Start Date  

 Click on Project Tab>> Properties Group>> Project Information.  

 A Dialog Box will appear on your screen. In the box for Start date, enter the start 
date. For example- start date is 11/5/20 . You can click the down arrow and 
choose the date from the calendar.  

 Tap on Ok to confirm.  

 
 

Step 2: Set up Calendar 

 Click Project Tab>> Properties Group>> Project Information.  

 Click on the arrow present on current date drop-down box. Here, you will see the 
list with three base calendars.  

 24 hour- Calendar having 24 hour working time.  

 Standard - Regular working hours from Monday to Friday with 1-hour break.  (8 
AM to 5 PM).  

 Night shift - It includes the timing from 11 PM to 8 AM. Night shift includes the 
nights from Monday to Friday.  

As mentioned in picture above, you have to choose the Standard Calendar as a Calender 
of your project. Tap on ‘Ok’ or ‘Cancel’ for closing the dialog box. Now, you have to add 
the exceptions.  

 
 

Step 3 - Adding the Exceptions to Calendar  

 
Exceptions are used for modifying the Project Calendar to have a non-working day or 
non-standard workday.  A user can also fix unique work hours for an individual resource.  

Example of creating a non-working day for any office celebrations or holiday: 
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Click Project tab>> Properties Group>> Change Working Time. 

 
The  Change Working Time Dialog box will get displayed on your screen.  Under the 
Exception Tab, click ‘Name Field’, enter the event as ‘ Company Anniversary’. Enter 
‘11/22/15’ in the Start field  and then enter the same in the finish field.  This day will be 
scheduled as the project’s non-working day as shown below in the picture. 

 
Step 4 - Setup Resource Calendar  

You can modify the Standard Base Calendar,  in the same manner, you can also modify 
the working and non-working time of every resource. A user can make the modifications 
in the resource calendar to accommodate vacation time, flex time, training time, etc.  

Resource Calendar can be set only for work resources not cost or material resources.  

 
Step 5 - Change the working time for resource  

 Click on the Project Tab and then go to Properties Group>>  Change working time. 
The  ‘Change Working Time Dialog Box’  will display on the screen. 

 Click down arrow for ‘For Calendar’ drop down box.  
 Choose the resource for whom you want to modify the work schedule.  
 Click ‘Works Week’ tab.  
 Double-click the [default] cell present just below the Column heading.  
 Under the ‘Selected day(s)’, select any day for changing the work schedule.  
 Click on Set day(s) to these particular work times as shown in the image below. 

  

Step 6 -  Create Non-Working days  

 Click on the Project Tab and then go to Properties Group>>  Change working time. 
The  ‘Change Working Time Dialog Box’ will display on the screen. 

 Click down arrow for ‘For Calendar’ drop down box.  
 Choose the resource for whom you want to modify the work schedule.  
 Click ‘Work Weeks’ tab.  
 Double click the default cell present below the ‘Name Column Heading’.  
 Under the Selected day, select the day for which you want to change the work 

schedule.  
 Click on any day. Use the radio button ‘Set days to non-working time’. 
 Tap on the OK button and close the dialog box.  
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Change Default Time Dimensions : Click on the Project Tab>> Properties Group>> 
Change working time>> options.  
 

Create Milestone: Milestones are particular points in the timeline of the 
project.  Milestones are used as main progress point for managing the project success 
and expectations of stakeholders.  These are basically used for budget, input, and 
reviews.  

As per the Mathematics, Milestone is a task of 0 duration. A user can insert a milestone 
in two different ways: 

 
Method 1 - Insert Milestone 

 Click task name to insert Milestone.  
 Click Task Tab>>Insert Group>> Milestone.  

 
Method 2 - Convert a Task to Milestone  

 Click on a specific task or enter the new task under Task Name Heading. 
 Under the heading Duration, type ‘0’ days.  

 
Method 3 - Convert a Task to Milestone 

 Double-click on a specific  Task name. 
 Task Information dialog box will appear on your screen. 
 Click on the Advanced tab and choose  “Mark Task as Milestone” as mentioned in 

the picture below. 

 
Create a Summary Task 

A user can roll up the different tasks in the project schedule into a Summary Task. This 
will help the users to manage the plan in a better way as a user can organize the plan 
into phases.  

For example- if a user wants to group Task 4 and Task 5 into the summary Task, a user 
can follow the given steps: 

 Select the name of both tasks.  
 Click the Task tab and then click on Group Insert.  
 Click summary.  
 MS project will create the New Summary task. Name it as Task 1.  
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Link Tasks 

Once you have made the task list for accomplishing targeted goals, you are supposed to 
link task with task relationships known as dependencies.  For example - After completion 
of task 1, task 2 will start, these dependencies are referred to Links.  

There are 4 types of task dependencies as mentioned below: 

 Finish to Start (FS)  
 Finish to Finish (FF) 
 Start To Start (SS) 
 Start to Finish (SF) 

 
 
Methods to link tasks 

Method 1 

Select the tasks that you want to link. For example Task 1 and Task 2. Here is the process 
to link tasks  

 Click on the task tab.  
 Schedule group.  
 Link the tasks selected.  
 Task 1, as well as Task 2, is linked to the FS-Finish to Start. 

 Important - The Start Date of Task 2 will be a day come after the finish date of Task 1. 

Method 2 

You need to Double Click on the targeted successor task for linking.  

For example - If you have clicked the  Task 4.  

 The task information dialog box display on your screen. 
 Click on the  ‘Predecessors’ tab 
 Now, you have to click on the empty cells in the table which are displayed below 

‘Task Name Column.  
 A drop-down menu will appear where all the tasks defined in the project are 

mentioned.  
 Choose Predecessor task and tap on OK. 

 

Method 3  

Here, you need to choose the task group and link them to Finish to Start relationship.  

Choose multiple tasks >>Task tab >>Schedule group>> Link the Selected Tasks. 
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Respect Links 

If you are working in a Manual Schedule Mode then, if you make any changes in the 
Predecessor task, the changes won’t get reflected in the start date of Task 4. For example 
- If the task 4 start on same that which is next day to the Task 3 finish date.  Then, the 
Task 3 duration will be changed from 5 to 7 days.  

Task 4 start date will not be updated automatically.  

If a user wants to change the default Scheduling Mode for all new Project Plans then: 

 
Go to the ‘File’ tab.  

 Click ‘Options’ and after that select ‘Scheduled’ Tab.  
 Select ‘All New Project’ from the scheduling option.  
 From the Drop down menu, choose ‘Auto Scheduled’ under the New Task creates 

as shown below.  

MS Project - Settings 

 
Every user has different Settings for their MS Project. To make sure that you get the expected 
outcomes without any hassle, you need to perform the following settings in your MS 
Project.  

Important- All these are the Default Settings that comes with MS Project installation.  

Step 1: Go to File>> Options. Click on the General Tab, select the Project view >> Default View.  

From the Drop down menu, choose ‘Gantt With Timeline’ option like mentioned below. 

Step 2: Go to ‘Files’>>’Options’>>’Display Tab’>>’ Show Indicators and Option Button for’.  

Check all the available options as shown in given screen. 

Step 3: Go to ‘File’>>’Optios’>>’ Scheduled tab’>> ‘Schedule’>>’ Show Assignment 
Units’. 

From the drop-down menu, select the ‘Percentage’ option as given below in the picture.  

 
Step 4: Go to ‘Files’>>’Options>>’ Schedule tab’>>’Calculation’>>’Calculate Project after 
each Edit’.  

Check ‘ON’ button.  

Step 5: Go to ‘Files’>>’Options>>’ Save Tab’>>’ Save Projects’>>’ Save Files In this 
format’.  

Choose ‘ Project (*.mpp)’. 

Step 6: Go to ‘File’>>’Options’>>’Advanced Tab’>>’Edit’.  
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Check All Options.  

Step 7: Go to  ‘File’>> ‘Options’>> ‘Advanced tab’>> ‘Display’>> ‘Show Status Bar’>> 
‘Show Scroll Bar’. 

Check the option ‘Scroll Bar’ and ‘Status Bar’ as shown in the picture. 

Step 8: Go to ‘Resources’>> ‘Level’>> ‘Leveling Options’>>’ Leveling Calculations’. 

Set it to the manual and you will see the following screen. 

Step 9: Go to ‘Resources’>> ‘Level’>> ‘Leveling Options’>>’ Leveling Calculations’>> 
‘Look for the Over allocations’.  

 

Microsoft Project Working Path: Open a blank Project -> File -> Info -> 
Project information -> Project Properties (Summary -> Fill up -> Ok) -> 
Organizer -> Calendars -> Go to the ‘Project’ by clicking on Back-Arrow -> 
Project [Change Working Time -> Create New Calendar ->  Name(PGCIL 
Calendar) -> Checked ‘Create New Base Calendar’ -> Ok -> Details (Give 
input for Working, Non-working and Holidays -> give time for everyday (from 
-> to) -> Ok. Exception -> List out the holidays] - > Task Name [Foundation 
as event with 0day Duration (Excavation 3 days -> PCC 2day -> Formwork 
Fdn 4day -> Fdn & Col Reinf. 5days -> Foundation -> Concreting Fdn 2day 
-> Formwork Column 3day -> Concreting Column 4day -> Removal of 
Formwork 7days) -> Fill the Duration for each task] -> Task Mode [Auto 
Schedule => File -> Option -> Schedule -> New Tasks Created (Auto 
Scheduled)] -> Link [Double click on PCC -> Predecessor (ID =2, Because 
PCC starts after excavation which has task sequence 2 (Task sequence 1 is 
for Foundation Task Name with zero day duration) -> Similarly for Formwork 
Fdn ID = 3 that is Task no. of PCC -> Similarly the other activity’s ID need to 
be filled with predecessor ID Number]. 

Work Breakdown Structure (WBS) in MSP: 

A Work Breakdown Structure (WBS), in project management and system 
engineering, is a deliverable-oriented decomposition of project into smaller 
components. A WBS is a key project deliverable that organizes the team’s work into 
manageable sections. 
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WBS Naming Convention: 

Path: Project -> WBS -> Define Code [(Level – Sequence – Length – Separator) -> 
Sequence (Uppercase Letter orders) -> Length (1) -> Separator (- hypen) -> Ok] ->  
Select Task Name (Right click -> Insert Column) -> Select or type WBS (See the WBS 
Numbering. Similarly, Sequence (Lowercase Letter orders) -> Length (1) -> 
Separator (. dot) -> Ok] ->  See the WBS Numbering. 

 

Level Resources 

MSP Path => Go to Menubar -> RESOURCE Tab -> Level Resources -> Select the over 
allocated resource (Level Now).  
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Other way: Go to Menubar -> RESOURCE Tab -> Level All. 

Levelling Option: Go to Menubar -> RESOURCE Tab -> Levelling Option (Levelling 
Calculation -> Checked Automatic and see the dropdown, say, select ‘day by day’) 
-> Levelling range for new product launch (level for entire project or within some 
time duration, From To) ->  Resolving overallocation (Checked options suitably). 

Clear Levelling: Go to Menubar -> RESOURCE Tab -> Clear Levelling (Checked ‘Entire 
project’ or ‘selected task’) 

Next Overallocation: Go to Menubar -> RESOURCE Tab -> Next Overallocation (The 
over allocation Red sign selection moves to the next overallocation). 

 

 

 

Resource Analysis:  

One of the most important aspects of your role is to monitor the assignments for 
each of your resources so that you caneffectively balance their workloads. Some 
resources might be overallocated, and others might be underallocated. You can 
review how efficiently your resources are being used in your project, and whether 
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you need to make any adjustments, by viewing their workloads and availability in 
Microsoft Project. 

MSP Path: Task menu -> Gantt Chart dropdown menu ->  ‘Resource Sheet’ [the red 
colored resources are overallocated -> Right click on the column (Insert a new 
column and give a column name say, ‘Peak’) ->  Change the max value same as peak 
value. 

 

Grouping: View -> Group by (Milestone or Critical, No Group, etc.) ->  Format Tab 
(Critical Tasks) -> Group by (New Group – give a name as ‘Resource Group by Deptt.’ 
-> Field name ‘Resource Group’ -> Apply) -> View (Resource Sheet & Resource 
Usage). 
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3. Data Analysis using Primavera 
 

Management Techniques in Construction – PERT & CPM 

To comprehend the scheduling of any project execution plan, let us understand 
first the basic concept of the following: 

- Project Management 
- Phases of Project Management 
- Guidelines for Network Construction 
- Critical Path 

Project Management:  

i) A project consists of individual activities, which are to be executed in a 
certain order before the entire task is completed.  

ii) The activities are interrelated in a logical sequence that is known as 
precedence relationship.  

iii) Project is represented in the form of a network for the purpose of 
analytical treatment to get solutions for scheduling and controlling its 
activities. 

 

Techniques in Project Management (for scheduling of project activities): 
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I) CPM – Critical Path Method: In this method, the activity’s timings are 
deterministic in nature.  CPM is deterministic, i.e, with fixed activity time. 
CPM is usually used in repetitive type of project management.  

II) PERT – Project Evaluation and Review Technique: In this method, the 
activity’s timings are probabilistic in nature, i.e, activity duration is not 
certain. PERT technique is usually used in a new project for project 
management.  
In PERT, Activity duration follows “Beta” distribution. And Each activity 
will have three different time estimates. These are: 

 Optimistic Time (to) – Favorable condition 

 Most likely time (tm) – Average condition 

 Pessimistic time (tp) – Adverse condition 

To note that, tp > tm > to 

Phases of Project Management: 

1) Planning   
- Dividing the project into distinct activities 
- Estimating time requirement for each activity 
- Establishing precedence relationships among the activities 
- Construction of the arrow diagram (Network) 
2) Scheduling  
- Determines the start and end time of each and every activity 
3) Controlling   
- Using the arrow diagram and time chart for continuous monitoring and 

project reporting 
 

Guidelines for Network Construction 

1. The starting event and ending event of an activity are called tail event and 
head event, respectively. 

2. The network should have a unique starting node (Tail Event). 
3. The network should have a unique completion node (Head Event). 
4. No activity should be represented by more than one arc in the network. 
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5. No two activities should have the same starting node (Starting Event) and 
the same ending node (Ending Event). 

6. Dummy activity is an imaginary activity indicating precedence relationship 
only. Duration of a dummy activity is zero. It is required when Start node and 
End node are same for two activities. It does not consume any resource or 
time. This is used to satisfy the predecessor relation only. We can use any 
nos. of dummy activity as required to satisfy the relation. 

7. There should not be any closed looping and dandling (open ended node) in 
the network. Dangling should be connected (ended) to next or end event 
(node). 

8. Fulkerson’s Rule is used for numbering of nodes(events). Say, i as start 
node(Tail Event) and j as end node (Head Event), as per Fulkerson’s rule j > i. 

 

 

 

 

 

 

 

 

 

Let us see Activity Time by an example: Time provided for a work = 7 days, but 
actual time required (dij) to complete the work is say, 3 days [Relax = (7-3) = 4 days]. 

 

 

 

 

Activity 
Time 

Start Time Finish Time 

Earliest Start Time Latest Start Time Earliest Finish Time Latest Finish Time 

[E] [L] [EFT] [LST] 

B A 

  

Ei = 0 

Li = 4 

i j 

Ej = 3 

Lj = 7 

dij =3 

(LST) (LFT) 
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Example -1 (CPM): Consider the details of a project as shown in the table 
below 

Activity Predecessor Duration (Months), (Dij) 
A - 2 
B - 5 
C - 4 
D B 5 
E A 7 
F A 3 
G B 3 
H C,D 6 
I C,D 2 
J E 5 
K F,G,H 4 
L F,G,H 3 
M I 12 
N J,K 8 

 

Questions: 

a) Construct the CPM Network 
b) Determine the critical path and project completion time 
c) Compute total floats and free floats for non-critical activities 
d) What is the Slack Time at each event (node)? 

 

Critical Path – The CPM Network 

Condition of Critical Path: 

i) ESi = LCi 
ii) ESj = lCj 
iii) ESj – ESi = LCj – LCi = Dij 

 

 



Page 27 of 66 
 

 

  Latest Completion Time (LC) 

  Earliest Start Time (ES) 

 

 

 

 

 

 

 

 

 

 

 

 

Critical Path: 

Critical Path of a project network is the longest path in the network. This can be 
identified by simply listing out all the possible paths from the start node (event) of 
the project to the end node (event) of the project and then selecting the path with 
the maximum sum of activity times on that path. 

Two phases: 

i) Determine Earliest Start times (ES) of all the nodes (events). This is called 
Forward Pass. 

ii) Determine Latest Completion times (LC) of various nodes (events). This is 
called Backward Pass 

I(2) 

J(5) 

B(5) G(3) 
1 

2 

3 

4 

5 8 

6 

7 

9 0 

0 

8 

2 

5 

5 

10 

10 

15 

9 

16 

16 

16 

12 

20 

20 

28 

28 

x 

y 
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Determination of Earliest Start Time => Forward Pass => ESj = maxi (ESi + Dij) 

For Node 1   ES1 = 0 (Always zero) 

For Node 2   ES2 = 0 + 2 = 2 

For Node 3   ES3 = 0 + 5 = 5 

For Node 4   ES4 = 5 + 5 = 10 

For Node 5   ES5 = 2 + 7 = 9 

For Node 6   ES6 = 10 + 6 = 16 

For Node 7   ES7 = 10 + 2 = 12 

For Node 8   ES8 = 16 + 4 = 20 

For Node 9   ES9 = 20 + 8 = 28 

Determination of Latest Completion Time => Backward Pass => LCi = Minj (LCj-Dij) 

For Node 9   LC9 = 28 (Always Max. ES) 

For Node 8   LC8 = 28 - 8  = 20 

For Node 7   LC7 = 28 - 12 = 16 

For Node 6   LC6 = 20 - 4 = 16 

For Node 5   LC5 = 20 - 5 = 15 

For Node 4   LC4 = 16 - 6 = 10 

For Node 3   LC3 = 10 - 5 = 5 

For Node 2   LC 2 = 15 - 7 = 8 

For Node 1   LC1 = 5 - 5 = 0  

Critical Path => The Largest Path in the Network. Here node  (event) 1-3-4-6-8-9 is 
the critical path, i.e, Total Time required to complete the project, i.e project 
completion time along with Critical Path = Duration for activity B + D + H + K + N = 

5 + 5 + 6 + 4 + 8 = 28 months (tcp). 
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Total Float (TF): 

It is the amount of time that the completion time of an activity can be delayed 
without affecting the project completion time. Therefore, the formula for Total 
Float calculation for each activity is: 

TFij = LCj - Esi - Dij 

Free Float (FF): 

It is the amount of time that the activity completion time can be delayed without 
affecting the earliest start time of immediate successor activities in the network. 
Therefore, the formula for Free Float calculation for each activity is: 

FFij = Esj - Esi – Dij 

 

Summary of Total Floats and Free Floats 
Activity (i,j) Duration (Dij) Total Float (TFij) Free Float (FFij) 

A        1,2 2 8 – 0 – 2 = 6 2 – 0 – 2 = 0 
B        1,3 5 5 – 0 – 5 = 0 5 – 0 – 5 = 0 
C        1,4 4 10 – 0 – 4 = 6 10 – 0 – 4 = 6 
D        3,4 5 10 - 5 – 5 = 0 10 – 5 – 5 = 0 
E        2,5 7 15 -2 – 7 = 6 9 – 2 – 7 = 0 
F        2,6 3 16 – 2 – 3 = 11 16 – 2 – 3 = 11 
G        3,6 3 16 – 5 – 3 = 8 16 – 5 – 3 = 8 
H        4,6 6 16 – 10 – 6 = 0 16 – 10 – 6 = 0 
I        4,7 2 16 – 10 -2 = 4 12 – 10 – 2 = 0 
J        5,8 5 20 – 9 – 5 = 6 20 – 9 – 5 = 6 
K        6,8 4 20 – 16 – 4 = 0 20 – 16 – 4 = 0 
L        6,9 3 28 – 16 – 3 = 9 28 – 16 – 3 = 9 
M        7,9 12 28 – 12 – 12 = 4 28 – 12 – 12 = 4 
N        8,9 8  28 – 20 – 8 = 0 28 – 20 – 8 = 0 

 

Any critical activity will have zero total float and zero free float, based on this 
property can determine critical activities. Therefore, B, D, H, K and N are critical 
activities. 

Hence, 1 – 3 – 4 – 6 – 8 – 9, i.e,  B – D – H – K – N  = 5 + 5 + 6 + 4 +8 = 28 months. 
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Slack Time at each Event (Node): 

Formula for determine “Slack Time” = LC – ES, i.e, Latest Completion time minus 
Earliest Start time. Note that, “Slack Time” for Events on Critical Path is zero (0). 

Event (Node) or Operation Slack Time = (LC – ES) 
1 0 – 0 = 0 
2 8 – 2 = 6 
3 5 – 5 = 0 
4 10 – 10 = 0 
5 15 - 9 = 6 
6 16 – 16 = 0 
7 16 -12 = 4 
8 20 – 20 = 0 
9 28 – 28 = 0 

 

CPM (Floats): 

Float is defined as the Relax or Delay provided to any activity. 

Relax or Float = Time provided – Duration of any activity (dij) 

Types of Float: 

i) Total Float (TF) 
ii) Free Float (FF) 
iii) Independent Float (IF) 

Let us understand the various types of floats in details with an example: 

 

 

 

 

 

Total Float (TF): The maximum Relax or Delay provided to any activity without 
affecting project duration. 

C B A 
    

Ei = 2 

Li = 6 

i j 

Ej = 15 

Lj = 20 

dij =5 
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Ei = 2 => Earliest Start Time (EST) of activity A 
Lj = 20 => Latest Finish Time (LFT) of activity A 
Therefore, (TF)A = [Time provided – Duration] => [(Lj - Ei) – dij] = [(20 – 2) – 5] = 13 days 
 
Free Float (FF): Relax or Delay provided to any activity without affecting EST of 
successor. 
Ei = 2 => Earliest Start Time (EST) of activity A 
Ej = 15 => Earliest Start Time (EST) of successor activity C 
Therefore, (FF)A = [Time provided – Duration] => [(Ej - Ei) – dij] = [(15 – 2) – 5] = 8 days 
 

Independent Float (IF): Relax or Delay provided to any activity without affecting EST of 
successor as well as LFT of predecessor. 
Ej = 15 => Earliest Start Time (EST) of successor activity C 
Li = 6 => Latest Finish Time (LFT) of predecessor activity B 
Therefore, (IF)A = [Time provided – Duration] => (Ej - Li) – dij = (15 – 6) – 5 = 4 days 
 

Note: 
i) TF > FF > IF 
ii) TF = FF = IF = 0 in Critical Path 
iii) Tail Event Slack at node i = Si = Li – Ei  
iv) Head Event Slack at node j = Sj = Lj – Ej 
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To understand the Floats from a diagram point of view: 
 
 

 

 

 

 

 

 

 

 

 

 

 

Example -2 (PERT):  Consider the following table summarizing the details of a 
project  

Activity Predecessor Duration 
(Weeks) 

Mean Duration, Dij 
(Expected Duration) 

Variance 

to tml tp te = (to+4tml+tp)/6 V =  2 = [tp – t0)/6]2 

A - 5 6 7 6 0.11 
B - 1 3 5 3 0.44 
C - 1 4 7 4 1.00 
D A 1 2 3 2 0.11 
E B 1 2 9 3 1.78 
F C 1 5 9 5 1.78 
G C 2 2 8 3 1.00 
H E,F 4 4 10 5 1.00 
I D 2 5 8 5 1.00 
J H,G 2 2 8 3 1.00 

Tail Slack 

TF = (Lj - Ei) - dij 

A 
  

Ei = 2 

Li = 6 

i j 

Ej = 15 

Lj = 20 

dij =5 

Ei Li Ej Lj 

FF = (Ej - Ei) - dij 

FF = (Ej - Li) - dij Head Slack 
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Questions: 

a) Construct the project network 
b) Find the expected duration and variance of each activity 
c) Find the critical path and expected project completion time 
d) What is the probability of completing the project on or before 22 weeks? 

Critical Path – The PERT Network 

Condition of Critical Path: 

i) ESi = LCi 
ii) ESj = lCj 
iii) ESj – ESi = LCj – LCi = Dij 

 

  Latest Completion Time (LC) 

  Earliest Start Time (ES) 

 

 

 

 

 

 

 

 

 

 

 

D(2) 

B(3) E(3) 
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2 

3 

4 

5 

6 

7 

8 

4 

4 

6 

3 

10 

6 

0 

0 

14 

14 
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9 

12 
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17 

17 

x 

y 
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Earliest Start Time => Forward Pass => ESj = maxi (ESi + Dij) 

Latest Completion Time => Backward Pass => LCi = Minj (LCj-Dij) 

Critical Path => The Largest Path in the Network, Here node (event) 1-4-6-7-8 is the 
critical path, i.e, Total Time required to complete the project, i.e project completion 
time along with Critical Path = Duration for activity C + F + H + J = 4 + 5 + 5 + 3 = 17 

weeks (tcp). 

Therefore, Standard Deviation, = Sqrt (Variance of Critical Path) = Sqrt(Variance 
of C+F+H+J) = Sqrt [(1.00+1.78+1.00+1.00) = 4.78] = 2.19 

Hence, Probability = P(t<=22) = P[z<=(t-tcp)/] = p[z<= (22-17)/2.19] = P[z<=2.28] 
= 0.9887. Now, refer standard deviation Chart w.r.t 2.28, i.e, 2.2 and 0.08, the value 
we get = 0.9887. This value is obtained from standard normal distribution table. 
Therefore, the probability of completing the project on or before 22 weeks is 
0.9887, i.e, 98.87% 

PERT (Probability): 

 

 

 

 

 

 

 

 
 

 

 

 
P = 68.30% 

` 

50% 50% 
` 

z = 0 

P = 50% 

P = 100% 

(+)∞ (-)∞ 

In PERT, Project Duration follows “Normal 
Distribution”. 

 => Mean Completion Time. 

 => Standard Deviation.  

X => Maximum Time Require to complete the 
project. 

Z => Standard Normal Deviate = ( x –  ) /  

(+)∞ (-)∞ 

Z => Standard Normal Deviate = ( x –  ) / 

For z = -1, Probability (P) = 50% - (68.3/2)% = 15.85% 

For z = +1, Probability (P) = 50% + (68.3/2)% = 84.15% 
z = (+)1 z = (-)1 
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E.g: For a construction project, the mean and standard deviation of completion 
time m = 200 days and s = 6.1 respectively. Assume normal distribution and use 
the value of standard normal deviate z = 1.64 Fot the 95% confidence level, the 
maximum time required for the completion of the project (x) would be… 

We know that the Standard Normal deviate, z = (x  - ) /  => z* +  = x => 1.64 * 
6.1 + 200 = x => x = 210 days.  

 

Z-table: A “z-table” also called the standard normal table, is a 
mathematical table that allows us to know the percentage of values below (to the 
eft) a z-score in a standard normal distribution (SND). 

P = 95.50% 

` 

(+)∞ (-)∞ 

Z => Standard Normal Deviate = ( x –  ) / 

For z = -2, Probability (P) = 50% - (95.5/2)% = 2.25% 

For z = +2, Probability (P) = 50% + (95.5/2)% = 97.75% 
z = (+)2 z = (-)2 

P = 99.70% 

` 

(+)∞ (-)∞ 

Z => Standard Normal Deviate = ( x –  ) / 

For z = -3, Probability (P) = 50% - (99.7/2)% = 0.15% 

For z = +3, Probability (P) = 50% + (99.7/2)% = 99.85% 
z = (+)3 z = (-)3 



Page 36 of 66 
 

 

 

Crashing of Project Network (Cost and Time Analysis): 

Crashing is defined as the process to reduce the project duration. By doing this the 
project cost may decrease or increase. 

 

  Latest Completion Time (LC) 

  Earliest Start Time (ES) 

x 

y 
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Time:  

Normal Time (TN) => Actual time required without any deduction of project 
duration. 

Crash Time (TC) => Reduced time for crashing the project duration by increasing 
resources, where TN > TC  

Cost:  

Normal Cost (CN) => Independent of project duration, e.g, material cost. 

Crash Cost (CC) => Extra money for extra resources for decreasing the project 
duration. Depends on project duration (pd). 

Overhead Cost (CO) => Cost associated with project duration, e.g, labor cost (say, 
Rs. 500/day). Depends on project duration (pd). 

Cost Slope or Crashing Cost: 

 

 

 

 

A(3) 
D(6) 

1 2 

3 

4 

3 

3 

0 

0 

8 

8 

15 

15 

A (TN = 6) 

2 4 
A (TC = 3) 

CN = Rs. 5000  CC = Rs. 6500 
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Cost Slope or Crashing Cost = [(CC  - CN) / (TN - TC) ] = (6500 - 5000) / (6 days - 3days)] 
= Rs. 500 / day. 

 

 

 

 

 

 

 

 

 

Now, Total Cost of the Project: 

= [Normal Cost (CN) + Crash Cost (CC) + Overhead Cost (CO)] 

= [Given + (n Nos. of day * CC per day) + (pd x CO per day)] 

 

Let us understand the “Total Cost” of a Project by an example: 

 

 

 

 

 

 

 

 

Note: 
 (x,y) => (TN,TC) = (Normal Time, Crashing Time) 
e.g, (3,1) => i.e, the activity can be done in 1 day. 
(z) => Crashing Cost (CC) per day 



TC  TN  

CN  

CC  

Co
st

 

Time 

Cost Slope or Crashing Cost  

=> tan = (CC – CN) / (TC  – TN)  

A(3,1) B(7,3) 
1 2 

3 

4 
 (4) (1) 
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If Overhead Cost (CO) is Rs. 4.5 / day and Normal Cost (CN) is Rs. 100. 

Find the Total Cost is this project is done in 6 days. 

Solution:  

 

  Latest Completion Time (LC) 

  Earliest Start Time (ES) 

 

 

 

 

 

Critical Path (C.P) = A – C - D 

Project Duration (p.d) = 12 Days. 

Now, Total Cost of the Project: 

= [Normal Cost (CN) + Crash Cost (CC) + Overhead Cost (CO)] 

= [Given + (n Nos. of day * CC per day) + (pd x CO per day)] 

= 100 + 0 + (12*4.5)  

= 154 Rs. (if the project is being completed as per normal duration, i.e, in 12 day). 

Now, by Crashing in Critical Path, the project is to be completed by 6 days. Here, 
this is to be noted that maximum crashing shall be done in activity where crashing 
cost is minimum (here Activity D, CC = Rs. 2) and also to note that here we can crash 
maximum 2 days(because the non critical path may be critical). 

Therefore, New project duration (p.d-New1) = 12 – 2 = 10 days 

And, New Total Cost = Previous Total Cost + Crash Cost – Overhead Cost 

      = 154 + (2 days * 2 Rs.) – (2 days * 4.5 Rs) 

A(3) B(7) 
2 

3 

4 
(1) 

1 
12 

12 

x 

y 

 (4) 
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      = 149 Rs. 

 

Now, Critical Path => A – C – D & A –B, both are critical path(s). 

 

 

 

 

 

 

 

 

Now, Find out the further crashing options.  

Try to crash equal nos. of days from each activity in parallel path. But in series, you 
can crash any activity in any order. 

i) By Crashing of Activity A, Crashing Cost = Rs. 4 per day 
ii) By crashing of Activity (B+C), Crashing Cost = Rs. (1+4) = Rs. 5 per day 
iii) By crashing of Activity (B+D), Crashing Cost = Rs. (1+2) = Rs. 3 per day 

Let us do the crashing of the activity whose crashing cost per day is minimum, Here, 
we can make crashing of B & D. So crash B+D by 1 day. 

Therefore, New project duration (p.d-New2) = 10 -1 = 9 days  

(Here, crashing in parallel, i.e, the deduction is 1 day in both the activity in parallel) 

And, New Total Cost = Previous Total Cost + Crash Cost of (B+D) – Overhead Cost 

      = 149 + (1 day * Rs. 1 + 1 day * Rs. 2) – (1 day * 4.5 Rs) 

      = 147.5 Rs. 

Again, Find out the further crashing options.  

A(3) B(7) 
2 

3 

4 
(1) 1 

10 

10 

 (4) 
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In series, you can crash any activity in any order. 

i) By Crashing of Activity A, Crashing Cost = Rs. 4 per day 
ii) By crashing of Activity (B+C), Crashing Cost = Rs. (1+4) = Rs. 5 per day 

Do the crashing of the activity whose crashing cost per day is minimum, Here, we 
can make crashing of A. So crash A by 2 day. 

Therefore, New project duration (p.d-New3) = 9 -2 = 7 days  

And, New Total Cost = Previous Total Cost + Crash Cost of A – Overhead Cost 

      = 147.5 + (2 days * Rs. 4) – (2 days * 4.5 Rs) 

      = 146.5 Rs. 

Now, the only crashing option left, that is B+C.  

i) By crashing of Activity (B+C), Crashing Cost = Rs. (1+4) = Rs. 5 per day 

Do the crashing of the activity whose crashing cost per day is minimum, Here, we 
can make crashing of A. So crash B+C by 1 day. 

Therefore, New project duration (p.d-New4) = 7 -1 = 6 days (Which is required) 

And, New Total Cost = Previous Total Cost + Crash Cost of A – Overhead Cost 

      = 146.5 + (1 day * Rs. 1 + 1 day * Rs. 4) – (1 days * 4.5 Rs) 

      = 147 Rs. (if the project is to be completed by 6 days) 

CPM Scheduling in Primavera: 

Primavera Path: To open the scheduling of project you may Press F9 or got to 
menubar and click on Schedule tab (Icon) -> a small task window name “Schedule” 
will pop-up. Click on ‘Schedule’ button. Go to “Layout: Classic Schedule Layout” -> 
Layout -> Open -> Select ‘CP Schedule Analysis’ (CP => Critical Path) -> Open -> Look 
at the ‘Early Start’; ‘Early Finish’; ‘Late Start’; and ‘Late Finish’ and ‘Total Float’ 
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columns. ->  

 

 

 

 

Work Flow Diagram in Construction Industry 

 

Site Mobilization –> Excavation -> Construction (Predecessor and successor) 

We need to identify which are the activities can start in parallel without any 
predecessor. 
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ES (Early Start) => EF (Early Finish) 

LS (Late Start) => LF (Late Finish) 

D (Duration) 

F (Float) – Float for an activity is the amount that its duration can slip without 
causing the project to be delayed. 

 

 

Forward Pass  Backward Pass & Float 



Page 44 of 66 
 

 
 

 

Project Management and Primavera 
 

Project Management life cycle includes 5 phases: 

 Initiating Process => Feasibility Study; Identify the Stakeholders; Scope; 
Schedule; Budget; Quality; Setting up Project office; Appoint the project 
team and Mobilization; Approval for the next phase. 

 Planning Process => Scope planning; Activity sequencing with duration; 
Resource planning & Organizational planning; Procurement planning, Quality 
planning; Costing.  

 Executing Process => Team; Contract; Scope verification; Information 
distribution; Quality assurance; Actual execution. 

 Controlling & Monitoring Process => Schedule control; Scope change control; 
Cost control; Risk Response control; Quality Control. 

 Closing Process => Project closure report that includes Project Overview, 
Result & Outcome, Project Cost, Project Performance Analysis, Challenges 
faced and Risk, Lessons Learned, Return of Experience.   
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What is Primavera? 

Primavera is a project management tool used of planning, tracking, scheduling, 
organizing, securing, managing the resources and tracking project progress, etc. 
that are needed to complete the project on-time and within budget. Primavera 
software is used of managing the organization’s programs and projects effectively 
irrespective of the complexity of the projects and can manage multiple projects in 
a single file. This tool provide the real time visibility of the status of the project(s) 
and further report to top management for better understanding of the project 
execution and better decision making. We can manage resources using the 
primavera P6 tool.   

 

Scheduling Terminology: 

Critical Path => is the longest path of the project. Any delay to an activity on this 
path will have an effect on the overall project finish date. 

Total Float => is the amount of time that an activity can be delayed without 
impacting the succeeding activity. 

Lag => is a way to delay or accelerate an activity’s start or finish date. If activity is 
delaying, the lag is called negative (-ive) lag and when the activity is accelerating, 
the lag is called positive (+ive) lag. 
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Relationship types => Finish to Start(FS); Finish to Finish (FF); Start to Start (SS); 
Start to Finish (SF). 

Predecessor and Successor => describing the order of activity in sequence. 
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4. Data Analysis using SAP & ERP 
 
What is an ERP? 
 E stands for Enterprise 
 R Stands for Resources 
 P Stands for Planning 

Enterprise resource planning (ERP) is defined as the ability to deliver an integrated 
suite of business applications. ERP tools share a common process and data model, 
covering broad and deep operational end-to-end processes, such as those found in 
finance, HR, distribution, manufacturing, service and the supply chain. 

 
Enterprise: 
Enterprise is another word for a for-profit business or company, but it is most often 
associated with entrepreneurial ventures. A business enterprise is always a for-
profit entity. The definition of an enterprise is simplified as a project, a willingness 
to take on a new project, an undertaking or business venture. An example of an 
enterprise is a new start-up business. An example of enterprise is someone taking 
initiative to start a business. 

Resources: 
An economic or productive factor required to accomplish an activity, or as means 
to undertake an enterprise and achieve desired outcome. Three most 
basic resources are land (Factories), labor (Man Power), and Money (capital); 
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other resources include material, machinery, energy, entrepreneurship, 
information, expertise, management, and time. 

However, there are four categories of resources, or factors of production: 
 Natural resources (land) 
 Labor (human capital) 
 Capital (machinery, factories, equipment) 
 Entrepreneurship. 

 

Further, an organization uses different resources to accomplish goals. The major 
resources used by organizations are often described as follow:  

 

(1) Human resources,  

(2) Financial resources,  

(3) Physical resources, and  

(4) Information resources. 

 
Planning: 
Planning is the process of thinking about the activities required to achieve a desired 
goal. It is the first and foremost activity to achieve desired results. It involves the 
creation and maintenance of a plan, such as psychological aspects that require 
conceptual skills. Some examples of various types of planning: 

 Strategic Planning  
 Project Planning 
 Timeline Planning 
 Production Planning 
 Capacity Planning 
 Demand Planning 
 Material Purchase Planning 
 Material Storage Planning 
 Organizational Change Management planning 

 
We make into a planning procedure and that planning procedure is called an ERP. 
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Let us consider a company ABC has five departments, namely: 

1) Purchase 
2) Production 
3) Sales 
4) Finance and  
5) HR 
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Example of ERP 
 Oracle Finance - Works for Finance only  
 People Soft  - Works for  HR only 
 Bann   - Works for Purchase and Production only 
 JD Edwards  - Works for Sales only 
 SAP   - Works for all departments in integration 

 

What is SAP? 
 S stands for System 
 A Stands for Applications 
 P Stands for Products   

SAP stands for Systems, Applications & Products in Data Processing 

SAP software products provide powerful instruments for helping companies to 
manage their financials, logistics, human resources, and other business areas. The 
backbone of SAP software offering is SAP ERP system which is the most advanced 
Enterprise Resource Planning (ERP) system from currently available ones. SAP SE is 
one of the largest vendors of enterprise resource planning (ERP) software and 
related enterprise applications. The company's ERP system enables its customers 
to run their business processes, including accounting, sales, production, human 
resources and finance, in an integrated environment. 



Page 52 of 66 
 

 

 

 

 

 



Page 53 of 66 
 

 

 

 

What is ABAP? - Back end of SAP System is ABAP 
 A stands for Advanced 
 B Stands for Business  
 A Stands for Application  
 P Stands for Programming Language   

 
Goods Receipt (GR) and Invoice Receipt (IR) in SAP 

1. PO No. 
2. Vendor Name 
3. Material Name 
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4. Quantity 
5. Plant Name 
6. Storage Location 

Goods Receipt in SAP is a confirmation, that the material mentioned in the 
Purchase Order has been received at the plant, which is mentioned in the PO 
document while creating. MIGO Transaction in SAP is important as it generates 
accounting and material document. With the goods receipt (GR) you post the 
physical inward movement of goods from an external vendor or from production 
and then complete a goods movement, which leads to an increase in the 
warehouse stock. Reserved quantities are displayed as planned receipts in the 
stock overview and plant stock availability. 

GR/IR is the SAP process to perform the three-way 
match – purchase order, material receipt, and vendor invoice.  You use a clearing 
account to record the offset of the goods receipt (GR) and invoice receipt (IR) 
postings.  Once fully processed, the postings in the clearing account balance. 
Clearing is performed at the purchase order (PO) line item level based on quantity 
entered. Price variance and exchange rate variance are calculated.  You can write 
off small differences using transaction MR1. 

 

 

 

Purchase Price Variance 
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This discussion assumes you are using standard price control (S) for purchased 
materials. The quantity and amount on the GR and IR postings are important. You 
must have posted GR to record purchase price variance (PPV). There is no PPV 
posting for just IR. There can be additional variance postings on IR after GR is posted 
for differences between PO price and actual price paid. When posting GR, the price 
variance is based on the PO price, unless IR has already been posted, then it is based 
on actual price paid. If IR has already been posted, the GR will be based on the IR 
up to the quantity of the IR, after that is will use the PO price again. After all 
postings to a PO line item, the net PPV posted will be the difference between the 
actual price paid and the standard cost of the material. 

 

Invoice Verification in SAP (SAP PO Cycle) 

 Invoice verification marks the end of procurement, after purchase order and 
goods receipt. 

 Invoice posting updates all the related documents in financials and 
accounting. 

 Blocked invoice that vary from actual invoice can be processed 
through invoice verification. 

The preferred method for verifying invoices is by email. Simply, your account 
manager sends an email to the accounts payable representative at your customer 
and gets the needed information. Since email doesn't always provide quick 
results, invoices can also be verified by phone. Invoice verification is about 
checking that you got what you paid for before progressing for payment. There are 
many factors that will influence the level at which an invoice is verified. These 
include:  

 The priority the organization puts on ensuring a correctly 
rendered invoice (paying for what you get). 

 The appetite for risk an organization has with respect to errors and mistakes 
not being discovered (cost leakage), as well as meeting audit requirements; 
and 

 Lacking the tools, defined processes and adequately skilled resources to 
perform the verification activities in a cost and resource effective manner. 
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Path in SAP: SAP menu -> Logistics -> Material Management -> Logistics Invoice 
Verification -> Document Entry -> MIRO Enter Invoice -> Copy PO No. -> Click on 
MIRO Enter Invoice -> Company Code -> Paste the PO No. -> Enter Invoice Date -> 
Transaction (Invoice, Credit memo, Subsequent debt, Subsequent credit) -> The top 
portion of the window below is called Header area and the bottom portion is called 
application area. 

 
 
 
 
P2P Process in SAP 
P2P is a process of obtaining and managing the raw materials needed for 
manufacturing a product or providing services and making payment for these. 
Procure to Pay (P2P) process is also known as an External 
Procurement Process. SAP Procure to Pay process is required when we need to 
purchase materials/services from an external vendor for our company. 
This process includes all the business tasks starting from a purchase requisition (PR) 
and finishing with payment to the vendor. 

Process of P2P:  
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1) Material requirement planning 
2) Purchase Requisition (PR –Entry in ME51N) to the purchase department 
3) Request for quotation to open market 
4) Vendor selection on the basis of quality and past experience 
5) Issue of Purchase Order (PO – Entry in ME21N) to the selected vendor 
6) Goods Receipt Note (GRN – Entry in MIGO) – vendor issue goods to the 

factory or plant 
7) Verification of invoice (MIRO) by finance department 
8) Payment to vendor (Entry in F-53) – Release payment to the vendor 
9) Vendor evaluation and reporting to the management 

 

Path in SAP: SAP menu -> Logistics -> Material Management -> Purchasing -> 
Purchase Order -> Purchase Requisition -> ME51N – Create (ME52N – Change, 
ME53N – Display) -> Double Click on ME51N – Create (The below window will pop-
up -> Fill the required data). 

 

 
Menupath for RFQ (Request For Quotation): SAP menu -> Logistics -> Material 
Management -> Purchasing -> RFQ/Quotation -> Request for Quotation -> ME41-
Create (ME42-Change; ME43-Display; ME44-Maintain Supplement; ME45-Release) 
-> Double Click on ME41-Create and provide the required data in the below 
window: 
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Follow the below window for Quotation: 
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Goods Receipt Note (GRN) 
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Sales Order MenuPath: SAP menu -> Logistics -> Sales and Distribution -> Sales -> 
Order (VA01 - Create; VA02 - Change; VA03 - Display). Double Click on VA01 – 
Create and make the necessary changes. 
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Nota Bene (N.B): Any suggestions for enriching the quality and usefulness of this article on “Brainstorming Management Talks” 
are most welcome and will be gratefully acknowledged with full fidelity.  I am looking forward to receive your goodwill thoughts 
to mature my sense of understanding. – Swarup Das [Mail: swarup_recj97@rediffmail.com; Mob: (+)91-8860451297] 
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Keep Conciliating “TIME” 
T stands for Trust. 

I stands for Involvement. 
M stands for Motivation. 

E stands for Enthusiasm/ Energy. 
 
 
 
 
 
 
 
 

“THE LESS SAID THE BETTER” 

“WE ARE POOR BECAUSE WE LACK ATTUTUDE” 
 

 
 

Thank You 
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For Managers 

Continual Improvement 

Data Analysis tools               
for EPC Companies 
MS Excel, MS Project, Primavera, 
SAP & ERP  

 

 

 

 

Swarup Das 
LET’S KEEP LEARNING 

The purpose of this book is to give guidance to the aspiring in EPC Companies, 
who dreams to become an experts in project management with knowledge of MS-

Excel, MS Project, Primavera and SAP & ERP. Further, this book will give you a 
comprehensive idea about the useful report generation using charts, graphs, etc. 

I believe that this book will enable you use your brain up to the fullest to work 
smartly and achieve your goal in all endeavor. I fervently hope that this book will 

help the managers / Leaders to get a sound understanding of how to plan your 
work and achieve your goals. I’m sure that this book fundamentally will increase 

your capability of getting good score in your organization, entrepreneurship and 
interviews in a stress-free manner. 




